Intermittent Login Issues and Errors in DonorPerfect
Incident Report for DonorPerfect
Resolved
This incident has been resolved. Thank you for being a DonorPerfect user!
Posted Jun 03, 2024 - 12:43 EDT
Monitoring
A fix has been implemented and we are monitoring the results. Thank you for your patience.
Posted Jun 03, 2024 - 12:09 EDT
Investigating
We're investigating reports of intermittent slowness, errors logging into the system and navigating within DonorPerfect. We apologize for this inconvenience, and we're working hard to resolve this issue.
Posted Jun 03, 2024 - 11:50 EDT
This incident affected: DonorPerfect.