Delay in Emails Being Delivered
Incident Report for DonorPerfect
Resolved
After monitoring, we have determined that the fix was successful, and we are now seeing prompt delivery of emails.

Thank you for your patience and understanding throughout this process.
Posted Oct 29, 2024 - 12:35 EDT
Monitoring
We have applied a fix and are closely monitoring the results. We are still seeing delays with email delivery for some email service providers.

If you are not currently receiving an email with the MFA Code, please do not request further codes. Please contact our support department, where we can assist you and provide you with the steps to log in to DP.

Thank you for your patience and understanding. We will keep you updated here.
Posted Oct 29, 2024 - 09:50 EDT
Identified
We have identified the cause of the email delivery delays and are actively working on a fix.

If you are not currently receiving an email with the MFA Code, please do not request further codes. Please contact our support department, where we can assist you and provide you with the steps to log in to DP.

Thank you for your patience and understanding. We will keep you updated here.
Posted Oct 28, 2024 - 16:40 EDT
Investigating
We are currently investigating a delivery delay for some emails sent through DonorPerfect and our suite of products. Please know that our team is working hard to identify the root cause and resolve this delay.

If you are not currently receiving an email with the MFA Code, please do not request further codes. Please contact our support department, where we can assist you and provide you with the steps to log in to DP.

Thank you for your patience and understanding. We will keep you updated here
Posted Oct 28, 2024 - 13:09 EDT
This incident affected: DonorPerfect.