DonorPerfect Chat is currently unavailable.
Incident Report for DonorPerfect
Resolved
Access to chat support and our Community site have been restored.
Posted 3 months ago. May 20, 2019 - 08:01 EDT
Identified
We are experiencing an issues with our chat support tool and as a result, it is not currently available. We are working with our service provider to restore its status. We apologize for the inconvenience and will keep you updated here.
Posted 3 months ago. May 17, 2019 - 11:15 EDT
This incident affected: DonorPerfect Community.