Intermittent Slowness Logging into DonorPerfect
Incident Report for DonorPerfect
Resolved
This incident has been resolved. Thank you for your patience and being a DonorPerfect user!
Posted Oct 06, 2022 - 20:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 06, 2022 - 20:16 EDT
Investigating
We're investigating reports of intermittent slowness when attempting to log into DonorPerfect. We apologize for this inconvenience, and we're working hard to resolve this issue.
Posted Oct 06, 2022 - 20:00 EDT
This incident affected: DonorPerfect and DonorPerfect Online Forms.