Performance Slowness

Incident Report for DonorPerfect

Resolved

After monitoring for a time we haven't experienced any additional slowness or timeout errors. Thank you for your patience and understanding!
Posted Mar 31, 2025 - 18:23 EDT

Monitoring

A fix has been implemented and we are monitoring the results. thanks for your patience as we worked to resolve this issue!
Posted Mar 31, 2025 - 16:43 EDT

Investigating

We are currently investigating some slowness and timeout errors when completing tasks in DonorPerfect. We are working hard to identify and fix the issue. Thank you for your patience and understanding. We will keep you updated here!
Posted Mar 31, 2025 - 15:17 EDT
This incident affected: DonorPerfect.