DonorPerfect Community Access

Incident Report for DonorPerfect

Resolved

This incident has been resolved and DonorPerfect Community is now active!
Posted Mar 08, 2025 - 06:58 EST

Investigating

We are currently investigating an issue where DonorPerfect Community is unable to be accessed. Your DonorPerfect database and Online Forms remain operational and working as expected. We will keep you updated as soon as we learn more. Thank you for your patience.
Posted Mar 07, 2025 - 20:42 EST
This incident affected: DonorPerfect Community.