Intermittent Issues Logging into DonorPerfect
Incident Report for DonorPerfect
Resolved
This incident has been resolved. Thank you for being a DonorPerfect user!
Posted Feb 26, 2024 - 17:37 EST
Monitoring
A fix has been implemented and we are monitoring the results. Thank you for your patience.
Posted Feb 26, 2024 - 16:11 EST
Update
We are continuing to investigate this issue and working hard to resolve it. Currently clients are experiencing intermittent errors when accessing records, navigating throughout DP and logging in. We apologize for any inconvenience and will keep you updated here.
Posted Feb 26, 2024 - 15:06 EST
Investigating
We are currently investigating an error appearing when attempting to log in to DonorPerfect. We are working hard to determine the root cause of this issue and resolve it as fast as possible. We will keep you updated here. Thank you for your patience.
Posted Feb 26, 2024 - 14:28 EST
This incident affected: DonorPerfect.