Third-Party Service Issues Affecting DonorPerfect, Classic and New Forms

Incident Report for DonorPerfect

Resolved

We haven’t seen any further issues, and our vendor has confirmed that the problem has been successfully resolved. We’re confident that everything is back to normal and running as expected. Thank you for your patience and understanding while we worked through this.
Posted Nov 18, 2025 - 14:00 EST

Monitoring

Our third party vender has implemented a fix and we are monitoring the results. we will update here again when we are confident this is fully resolved.
Posted Nov 18, 2025 - 09:50 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 09:23 EST

Identified

An issue has been identified with one of our third party venders that may be causing intermittent errors when accessing DonorPerfect, Classic and New Forms as well as ReadySetAuction. This appears to be connected to a widespread outage affecting many online services. We apologize and are working on resolving this.
Posted Nov 18, 2025 - 08:48 EST
This incident affected: DonorPerfect, DonorPerfect Classic Online Forms, New DonorPerfect Online Forms, and ReadySetAuction.