Phone Support Unavailable
Incident Report for DonorPerfect
Resolved
This incident has been resolved. Thank you for being a DP user!
Posted Feb 02, 2024 - 10:21 EST
Monitoring
A fix has been implemented and we are monitoring the results. Thank you for your patience!
Posted Feb 02, 2024 - 10:01 EST
Investigating
We are currently investigating an issue that is preventing access to our phone support. We are working hard to identify and resolve the issue, and we will keep you updated on the progress. The best way to reach our support team at this time is through Chat Support in the Help Menu of DonorPerfect (look for the question mark in the upper right corner).
Posted Feb 02, 2024 - 09:25 EST
This incident affected: DonorPerfect.