Errors logging into DonorPerfect

Incident Report for DonorPerfect

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 14:03 EDT

Monitoring

We have implemented a fix, and you should now be able to log in to DonorPerfect normally. Please note that you may be prompted for an MFA code again, even if you authenticated within the last 10 days. We will continue to monitor this fix and keep you updated here. Thank you for your patience and understanding.
Posted Sep 02, 2025 - 12:49 EDT

Update

We are currently investigating an issue when attempting to log in to DonorPerfect. We are working hard to identify and resolve this issue as soon as possible. We apologize for the inconvenience and will keep you updated here.
Posted Sep 02, 2025 - 11:36 EDT

Investigating

We are currently investigating an issue when attempting to log in to DonorPerfect. We are working hard to identify and resolve this issue as soon as possible. We apologize for the inconvenience and will keep you updated here.
Posted Sep 02, 2025 - 11:34 EDT
This incident affected: DonorPerfect.