Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2025 - 20:00 EST
Scheduled
On Thursday, February 27th at 8pm EST we will be performing maintenance to DonorPerfect Online Forms (DPForms). This maintenance is expected to last approximately 1 hour. During this time you may experience a single period of downtime of up to 5 minutes when trying to access DPForms. Your online forms will continue to processing as usual.
At 9pm EST we will also be performing maintenance to DonorPerfect. This maintenance is expected to last approximately 1 hour with approximately 15 minutes of downtime when accessing and trying to use DonorPerfect. Your online forms will continue to processing as usual.
Thank you for being a DP user and your understanding as we continue to improve DonorPerfect and Online Forms!
Posted Feb 26, 2025 - 12:10 EST
This scheduled maintenance affected: DonorPerfect and New DonorPerfect Online Forms.