We have implemented a solution to address the login and loading issues with DonorPerfect Online Forms Drag and Drop Builder. After monitoring the results, we haven't detected any new errors. If you are still encountering problems with loading the forms builder, please try clearing your browser’s cache and cookies. If you need assistance with this process, feel free to contact our support team, and we’ll be happy to help. Thank you for your patience and understanding as we worked to resolve this issue.
Posted Oct 24, 2024 - 09:26 EDT
Investigating
We are currently investigating an issue where the DonorPerfect Online Forms Builder (Drag and Drop Forms) is not loading when navigating to Apps > Online Forms > Drag and Drop Builder. Our team is actively working to resolve this. In the meantime, you can try clearing your cache and cookies or using an alternative browser. Your online donation forms are still processing donations during this time. We appreciate your patience and will provide updates here as soon as possible.
Posted Oct 23, 2024 - 18:00 EDT
This incident affected: New DonorPerfect Online Forms.