Errors Logging in & Navigating within DonorPerfect

Incident Report for DonorPerfect

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 16:58 EDT

Update

We are continuing to investigate intermittent errors affecting both login and navigation within DonorPerfect. We understand this issue has been impacting users throughout the morning and sincerely apologize for the ongoing inconvenience.

Our team is actively working to identify the cause and restore normal functionality as quickly as possible. We will continue to provide updates here as more information becomes available.
Posted Sep 03, 2026 - 14:06 EDT

Investigating

We’re currently investigating reports of errors when searching for records and navigating within DonorPerfect. We apologize for the inconvenience and are working to resolve the issue as quickly as possible. We’ll provide updates here as more information becomes available.
Posted Sep 03, 2026 - 12:03 EDT
This incident affected: DonorPerfect.