Performance Slowness

Incident Report for DonorPerfect

Resolved

This incident has been resolved. Thank you for being a DP user!
Posted Apr 24, 2025 - 13:06 EDT

Investigating

We are currently investigating some slowness and timeout errors when completing tasks in DonorPerfect. We are working hard to identify and fix the issue. Thank you for your patience and understanding. We will keep you updated here!
Posted Apr 24, 2025 - 10:14 EDT
This incident affected: DonorPerfect.