DonorPerfect Loading Issues & Errors
Incident Report for DonorPerfect
Resolved
Our team has identified the issue and resolved it. All systems should load correctly now. We apologize for any inconvenience this has caused. Thank you for being a DonorPerfect client!
Posted Feb 02, 2023 - 23:19 EST
Investigating
We are currently investigating an issue where some DonorPerfect systems are not loading correctly. Resolving this is a top priority and our development team is actively working on investigating the cause of this. We will keep you updated as soon as we have more information. We apologize for any inconvenience.
Posted Feb 02, 2023 - 22:43 EST
This incident affected: DonorPerfect.