Intermittent Errors

Incident Report for DonorPerfect

Update

We are continuing to investigate the root cause that has been impacting performance for DonorPerfect systems. Tomorrow, April 4th at 9pm Eastern, we will be completing maintenance that we believe will positively impact performance and help resolve the slowness and intermittent errors. We apologize for the time and impact this has had on your organization. We appreciate your patience and are working to actively ensure DonorPerfect is stable for all users!
Posted Apr 03, 2025 - 17:30 EDT

Update

We are continuing to investigate intermittent errors and slowness when navigating in DonorPerfect and completing tasks. We apologize for any inconvenience. This is a top priority that we are working hard to resolve. We will keep you updated here.
Posted Apr 02, 2025 - 17:27 EDT

Investigating

We are currently investigating intermittent errors when completing tasks in DonorPerfect. We are working hard to identify and fix the issue. Thank you for your patience and understanding. We will keep you updated here!
Posted Apr 02, 2025 - 11:42 EDT
This incident affects: DonorPerfect.