DonorPerfect Slowness and Intermittent Errors
Incident Report for DonorPerfect
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 16:30 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2022 - 13:22 EDT
Investigating
We're investigating reports of intermittent slowness, errors navigating within DonorPerfect, and completing tasks. We apologize for this inconvenience, and we're working hard to resolve this issue.
Posted Oct 13, 2022 - 13:10 EDT
This incident affected: DonorPerfect and DonorPerfect Online Forms.