After closely monitoring our fix, we’re confident the issue has been fully resolved. Logins have remained stable, and no further errors have been observed. Thank you for your patience and understanding as we worked to address the problem thoroughly.
Posted Jun 16, 2025 - 16:26 EDT
Monitoring
Thank you for your patience. Our team has identified the root cause and implemented a fix. We’re now seeing successful login attempts. We will continue to monitor the situation to ensure everything remains stable and fully resolved.
Posted Jun 16, 2025 - 15:04 EDT
Update
Our team continues to work on and investigate the root cause of this issue. We will provide an update as soon as we can. Thank you for your patience and understanding.
Posted Jun 16, 2025 - 14:34 EDT
Investigating
We are currently investigating an error that is appearing when attempting to login to DonorPerfect for some clients. This is a high priority for our team and we will keep you updated here.