Errors Running and Saving Easy Reports

Incident Report for DonorPerfect

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 11:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 11:12 EDT

Investigating

We are currently investigating an issue with DonorPerfect Easy Reports not loading or saving properly. We apologize for this inconvenience and will keep you updated on our progress here.
Posted Oct 29, 2025 - 11:02 EDT
This incident affected: DonorPerfect.