Intermittent Phone Connectivity Issues
Incident Report for DonorPerfect
Resolved
We received confirmation from our phone vendor that the fix they put into place worked and they are no longer seeing errors. Thank you for your patience!
Posted Jan 20, 2023 - 14:26 EST
Monitoring
A fix has been implemented by our phone provider and we are monitoring the results. Thank you for your patience.
Posted Jan 19, 2023 - 19:11 EST
Identified
The issue has been identified and we are working hard with our phone provider to resolve it. Currently, we are seeing intermittent issues with phone connectivity to our team. We apologize for any inconvenience.

Currently, if you are not able to connect with our phone team please reach out to us through our Chat Support Menu in DPO (look for the question mark in the upper right corner).
Posted Jan 19, 2023 - 15:36 EST
Investigating
We are currently investigating an issue that is causing connectivity issues with our phone support. We are working hard to identify and resolve the issue, and we will keep you updated on the progress.

The best way to reach our support team at this time is through Chat Support in the Help Menu of DonorPerfect (look for the question mark in the upper right corner).
Posted Jan 19, 2023 - 14:24 EST