MFA Emails Not Being Delivered
Incident Report for DonorPerfect
Resolved
We have not encountered any further issues or errors with the delivery of MFA emails. Thank you for your patience and understanding as we worked diligently to implement a solution that ensures consistent email delivery
Posted Sep 20, 2024 - 15:35 EDT
Monitoring
We implemented another fix and are beginning to see MFA emails being delivered again. If you previously experienced a delay, Please try again. Please note, there is a chance these emails may be routed to your junk or spam folder, so be sure to check there if you don't receive the email promptly. Thank you for your continued patience while we worked through this issue.
Posted Sep 20, 2024 - 13:53 EDT
Investigating
We are currently investigating an issue where some Multi-factor Authentication Emails are not being delivered. This is a top priority and we are working hard to resolve this. As soon as we know more we will update here. We apologize for any inconvenience this has caused.
Posted Sep 20, 2024 - 12:48 EDT
Monitoring
We implemented a fix and are happy to report that MFA emails are now being successfully delivered. If you previously experienced a delay, we encourage you to try again. Please note, there is a chance these emails may be routed to your junk or spam folder, so be sure to check there if you don't receive the email promptly. Thank you for your patience and understanding as we resolved this issue.
Posted Sep 20, 2024 - 10:26 EDT
Update
We are seeing Multi-Factor Authentication (MFA) emails successfully sent and delivered through our email service. We are continuing to investigate the root cause of this issue. Thank you for your understanding and patience while we work through and will keep you updated here.
Posted Sep 20, 2024 - 10:04 EDT
Investigating
We are currently investigating an issue where some Multi-factor Authentication Emails are not being delivered. This is a top priority and we are working hard to resolve this. As soon as we know more we will update here. We apologize for any inconvenience this has caused.
Posted Sep 20, 2024 - 09:21 EDT
This incident affected: DonorPerfect.