Microsoft Email Deliverability issue
Incident Report for DonorPerfect
Resolved
All emails are continuing to arrive at Microsoft mailboxes without any issue. Thank you again for bearing with us as we identified this issue and worked to resolve it. Have a happy Thanksgiving!
Posted Nov 28, 2024 - 11:05 EST
Monitoring
After an intervention from our partner, we are once again seeing emails deliver successfully to all email providers. We are keeping an eye on the emails being sent from DonorPerfect and Online Forms to make sure they continue to deliver successfully. Thank you for your patience as we worked to resolve this.
Posted Nov 27, 2024 - 20:37 EST
Identified
We have currently identified an issue where emails from both DonorPerfect and Online Forms are being blocked from being delivered to Microsoft emails (Hotmail, Outlook, Live, etc.). We have been working with our email provider closely to resolve this. This is a high priority issue that we are monitoring closely. We apologize for any inconvenience and will keep you updated here.
Posted Nov 27, 2024 - 19:16 EST
This incident affected: DonorPerfect, DonorPerfect Classic Online Forms, and New DonorPerfect Online Forms.