Slow or non-responsive Dashboards
Incident Report for DonorPerfect
Resolved
The Dashboards issue has been resolved.

Because we have seen intermittent Dashboard issues over the recent weeks, our team will be implementing a solution that we believe will permanently fix the specific Dashboard issue that you experienced today. We have isolated the traffic that has been causing issues, and our solution will route that traffic in a way that prevents any slowness or issues from occurring. Thank you for your patience as we work to resolve this issue, and we will keep you updated on the maintenance we plan to do to permanently resolve this issue.
Posted Oct 31, 2018 - 17:22 EDT
Investigating
We're investigating reports of slow and non-responsive dashboards. We hope to have this issue resolved as soon as possible.
Posted Oct 31, 2018 - 10:55 EDT
This incident affected: DonorPerfect.