DPMobile App Processing Issues

Incident Report for DonorPerfect

Resolved

This incident is resolved.
Posted Mar 27, 2026 - 20:04 EDT

Investigating

We are currently investigating an issue where DPMobile is unable to process new gifts within the app. Additionally, we are seeing that new API keys cannot be generated at this time.

Our team is actively working to identify the root cause, and we will continue to provide updates here as more information becomes available.
Posted Mar 27, 2026 - 19:15 EDT
This incident affected: DPMobile App & XML API.