Intermittent Errors Completing Tasks in DonorPerfect

Incident Report for DonorPerfect

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 14:02 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2026 - 12:40 EDT

Investigating

We are currently investigating intermittent errors when completing tasks in DonorPerfect. We are working hard to identify and fix the issue. Thank you for your patience and understanding. We will keep you updated here!
Posted Mar 27, 2026 - 11:14 EDT
This incident affected: DonorPerfect.