Intermittent Slowness and Errors in DonorPerfect
Incident Report for DonorPerfect
Resolved
This incident has been resolved. Thank you for your patience and being a DonorPerfect user!
Posted Mar 15, 2024 - 18:29 EDT
Update
We're continuing to investigate reports of intermittent slowness and errors logging into DonorPerfect. We apologize for this inconvenience and we will update you with any further information. Thank you for your patience.
Posted Mar 15, 2024 - 16:11 EDT
Investigating
We're investigating reports of intermittent slowness and errors navigating within DonorPerfect. We apologize for this inconvenience, and we're working hard to resolve this issue.
Posted Mar 15, 2024 - 14:46 EDT
This incident affected: DonorPerfect.