A fix has been implemented and we are monitoring the results. You should now be able to access the SafeSave Processing Gateway, Instacharge, and donors should be able to process donations through Drag-N-Drop Forms.
Posted Sep 26, 2025 - 18:24 EDT
Update
We have been informed by our payment processing partner of an upstream issue affecting our SafeSave Processing Gateway. We are working closely with them to identify and resolve the problem as quickly as possible.
During this time, some transactions may fail to download from Online Forms Classic into DonorPerfect, and you may experience errors when trying to edit gifts that have been processing previously by our processing gateway; however, payments are still being processed successfully within Online Forms Classic itself.
Posted Sep 26, 2025 - 17:34 EDT
Investigating
We are currently investigating a high-priority issue affecting the SafeSave Processing Gateway when using Instacharge and Drag-N-Drop Forms. At this time, attempts to access Apps → Processing Gateway are unsuccessful. Drag-N-Drop Forms and Instacharge are unable to process until this is resolved, but your Online Forms Classic is still processing at this time. Our team is working diligently to restore full functionality as quickly as possible, and we will share updates here as soon as more information becomes available.
Posted Sep 26, 2025 - 17:18 EDT
This incident affected: DonorPerfect, New DonorPerfect Online Forms, and SafeSave Payments Gateway.