Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2025 - 21:01 EDT
Scheduled
Tonight, June 18th at 8 PM EST, we will be deploying an update to DonorPerfect to address an issue where the multi-factor authentication (MFA) "remember me" option wasn't being respected. This maintenance is estimated to last approximately 30 minutes. During the maintenance window, you may experience intermittent connectivity issues for about 10 minutes. Your DonorPerfect Online forms, both new and classic, will continue to process without disruption. After the maintenance is completed all users will be prompted to enter an MFA code at next login. From there if the "remember me" option is selected it will work as expected. Thank you for your patience and understanding as we work to improve DonorPerfect.
Posted Jun 18, 2025 - 17:41 EDT
This scheduled maintenance affected: DonorPerfect.