Intermittent Payment Processing Issues

Incident Report for DonorPerfect

Resolved

This incident has been resolved. Thank you for being a DonorPerfect customer!
Posted Feb 02, 2023 - 19:15 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 02, 2023 - 17:50 EST

Investigating

Our payment processing vendor has reported that some clients could experience errors when attempting to process electronic payments. This would include transactions attempted in DP Online Forms, Instacharge, and Monthly Giving. We apologize for this inconvenience, and we have been notified that our partner's technicians are working on resolving the issue. We'll keep you updated as we receive updates from them.
Posted Feb 02, 2023 - 17:34 EST
This incident affected: SafeSave Payments Gateway.