Chat support unavailable

Incident Report for DonorPerfect

Resolved

This incident has been resolved, and Chat Support is now fully available. Thank you for your patience while we worked to correct the issue.
Posted Nov 03, 2025 - 14:01 EST

Investigating

We’re currently investigating an issue causing Chat Support to be unavailable. Our team is actively working to resolve the problem. In the meantime, we recommend using Phone Support for assistance. Updates will be posted here as they become available.
Posted Nov 03, 2025 - 12:57 EST