Intermittent Slowness and Errors in DonorPerfect
Incident Report for DonorPerfect
Resolved
This incident has been resolved. Thank you for being a DonorPerfect user!
Posted Apr 12, 2024 - 14:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results. Thank you for your patience.
Posted Apr 12, 2024 - 12:35 EDT
Investigating
We're investigating reports of intermittent slowness and errors navigating within DonorPerfect. We apologize for this inconvenience, and we're working hard to resolve this issue.
Posted Apr 12, 2024 - 12:25 EDT
This incident affected: DonorPerfect.