Phone Support Unavailable
Incident Report for DonorPerfect
Resolved
This incident has been resolved. We appreciate your patience. Thank you for being a DonorPerfect customer!
Posted Jan 18, 2023 - 17:11 EST
Monitoring
A fix has been implemented and we are monitoring the results. We appreciate your patience and thank you for being a DonorPerfect customer!
Posted Jan 18, 2023 - 14:52 EST
Identified
The issue has been identified and we are working hard with our phone provider to resolve it. Currently, we are seeing intermitted issues with phone connectivity to our team. We apologize for any inconvenience.

Currently, if you are not able to connect with our phone team please reach out to us through out Chat Support Menu in DPO (look for the question mark in the upper right corner).
Posted Jan 18, 2023 - 12:05 EST
Investigating
We are currently investigating an issue that is causing connectivity issues with our phone support. We are working hard to identify and resolve the issue, and we will keep you updated on the progress.

The best way to reach our support team at this time is through Chat Support in the Help Menu of DonorPerfect (look for the question mark in the upper right corner).
Posted Jan 18, 2023 - 11:20 EST
This incident affected: DonorPerfect.