No further errors were observed and this issue is resolved.
Posted Jan 23, 2026 - 14:59 EST
Monitoring
We have been notified that this issue has been addressed and all payment attempts are connecting as normal. We are monitoring payment success to ensure that this issue is truly resolved. Thank you for your patience as this situation was identified and addressed.
Posted Jan 23, 2026 - 12:21 EST
Investigating
We are currently monitoring a high-priority issue affecting the SafeSave Processing Gateway impacting Instacharge and Payment Forms. Some payment attempts are receiving connection error messages. Our team is working diligently with our partner to restore full functionality as quickly as possible, and we will share updates here as soon as more information becomes available.
Posted Jan 23, 2026 - 12:10 EST
This incident affected: DonorPerfect, DonorPerfect Classic Online Forms, New DonorPerfect Online Forms, and SafeSave Payments Gateway.