Errors Accessing DonorPerfect
Incident Report for DonorPerfect
Resolved
This incident has been resolved. Thank you for your patience and being a DonorPerfect user!
Posted Jan 22, 2025 - 08:22 EST
Investigating
We are currently investigating an issue affecting the ability to login to DonorPerfect without error for some clients. Your Online Forms should be still continuing to process without interruption. This is a high priority and we apologize for any inconvenience this might be causing you. We will keep you posted with updates here.
Posted Jan 22, 2025 - 08:07 EST
This incident affected: DonorPerfect.